Focus lost when logfile refreshes (live-logfile)

Notes, tips, and other usefull things on how to use LogMX

Moderator: admin

Post Reply
c0nnex
Posts: 8
Joined: Tue Sep 27, 2016 11:00 pm
Contact:

Focus lost when logfile refreshes (live-logfile)

Post by c0nnex » Tue Sep 27, 2016 11:15 pm

I recently moved from Log4View to LogMX (5.5.1 pro) and really missing a standard behavior of log4view :(

My software writes about 1000 logentries per second, read by a LocalFileparser into LogMX with autorefresh ( 100ms , 1000 entries max)

If I now focus a logentry to inspect it, while the program is running and logging, the focus of the inspected entry is lost every time, which is very frustrating.
This even happens when autofocus is off.

so 2 Questions:
a) how to prevent that the focus is lost when the logfile is refreshed/new logentries are loaded?
b) is there an option to disable autofocus automatically when i manually focus/click an entry?

Also, how can i disable the timeline warnings? (Program logs asynchronously to timestamps are not always in squence)

Thanks in advance
-Ulrich

admin
Site Admin
Posts: 437
Joined: Sun Dec 17, 2006 10:30 pm

Re: Focus lost when logfile refreshes (live-logfile)

Post by admin » Wed Sep 28, 2016 3:06 am

Hello Ulrich,

If the option "Always focus on new entries" is OFF, then a selected entry should not lose the focus, except if this entry has been removed from the log entries view because of your current view max size (options at the left of focus option). Depending on your available RAM, you can set it to a very high-number (around 1,000,000) to be sure. Otherwise, if this is not due to this limit, it's a bug, but we will need more information to reproduce/fix it: did the log entry just lose the focus? or did the entries table just scroll up/down? or maybe both?

In fact, the first time the feature "always-focus-on-last-entry" was released, we used this rule: when an entry was clicked, the option was turned OFF. But a lot of people didn't understand at first and/or found this annoying. I guess we could re-introduce this feature as an option (disabled by default). Would you like that?

Concerning the "timeline warnings", could you please send me a screenshot or copy/paste this warning? (there are a lot of different warning messages that could be displayed concerning the timestamps). I just had an idea: I don't know yet which kind of warning it is but instead of always displaying a warning message we can maybe add a warning icon somewhere if you click on a new option "Don't display again" that we could add.

Xavier

c0nnex
Posts: 8
Joined: Tue Sep 27, 2016 11:00 pm
Contact:

Re: Focus lost when logfile refreshes (live-logfile)

Post by c0nnex » Fri Sep 30, 2016 9:38 pm

Hi Xavier,
admin wrote: If the option "Always focus on new entries" is OFF, then a selected entry should not lose the focus, except if this entry has been removed from the log entries view because of your current view max size (options at the left of focus option). Depending on your available RAM, you can set it to a very high-number (around 1,000,000) to be sure. Otherwise, if this is not due to this limit, it's a bug, but we will need more information to reproduce/fix it: did the log entry just lose the focus? or did the entries table just scroll up/down? or maybe both?
Guess it was a memory issue. Boosted mem to 2 GB and now all seems to be fine. I'll observe if i can still reproduce the issue.
admin wrote: In fact, the first time the feature "always-focus-on-last-entry" was released, we used this rule: when an entry was clicked, the option was turned OFF. But a lot of people didn't understand at first and/or found this annoying. I guess we could re-introduce this feature as an option (disabled by default). Would you like that?
Sounds like a deal ;)
admin wrote: Concerning the "timeline warnings", could you please send me a screenshot or copy/paste this warning? (there are a lot of different warning messages that could be displayed concerning the timestamps). I just had an idea: I don't know yet which kind of warning it is but instead of always displaying a warning message we can maybe add a warning icon somewhere if you click on a new option "Don't display again" that we could add.
Trying to reproduce this. Seems not to happen anymore after ram-increase.

-Ulrich

Post Reply