Trouble with filters

Notes, tips, and other usefull things on how to use LogMX

Moderator: admin

isheedm
Posts: 109
Joined: Wed Sep 12, 2007 2:16 pm

Trouble with filters

Postby isheedm » Fri Jul 31, 2009 3:31 pm

I am trying to use filters and I'm having a problem with more than 2 rules. I've never had this problem before, but maybe it showed up in v1.3.3?

The filters I setup are:

Message contains Caching
OR Message like .*Got.*bytes.*
OR Message contains Releasing

The last filter about finding the text "Releasing" doesn't work. If I turn off the filter, I can clearly see entries in the table that have the text I'm looking for. If I change the last rule to be something very generic like:

OR Message contains "R"

it still doesn't work.

Message contains Caching
OR Message contains Releasing

works OK

I thought I would test to see if there was some problem with mixing contains and like operators, so I changed the original definition to be:

Message like .*Caching.*
OR Message like .*Got.*bytes.*
OR Message like .*Releasing.*

This did not work.

Message like .*Caching.*
OR Message like .*Got.*bytes.*

This works.

I guess it must be something about having more than 2 filters?

admin
Site Admin
Posts: 417
Joined: Sun Dec 17, 2006 10:30 pm

Postby admin » Sun Aug 02, 2009 4:56 pm

Hello,

You're right, it's a bug. Sorry for the inconvenience.

This error occurs when using at least 3 "OR" filters ("AND" filters don't produce this error). It will be fixed in v2.0.0.

Xavier.

admin
Site Admin
Posts: 417
Joined: Sun Dec 17, 2006 10:30 pm

Re: Trouble with filters

Postby admin » Sat Mar 20, 2010 3:39 pm

Hello,

LogMX v2.0.0 is now available, and include a fix for this bug, among other new features (http://www.logmx.com/p_download.php#ChangeLog).

Feel free to let us know if you have any other question or problem using LogMX.

Xavier.


Return to “Using LogMX”

Who is online

Users browsing this forum: No registered users and 1 guest